中国自动化学会专家咨询工作委员会指定宣传媒体
免费注册 登录 广告服务 | 客服中心
您现在所在的是:

变频器维修

抖音 西门子减速电机 德嘉 台达 英威腾 泓格论坛 西门子 我和LOGO!有个约会 FLIR红外热像论坛 【有奖活动】英威腾 “Ni美国国家仪器 “PLC发展趋势大讨论”活动圆满结束 cc-link图文征集活动 西门子SMART LINE V3
工控论坛首页 变频器维修 → 浏览主题: 三菱MR-J4-10A伺服器报AL32.4、AL32.1、AL24.2故障维修1例
发表新帖 回复该主题
回帖:4个,阅读:252 [上一页] [1] [下一页]
* 帖子主题:

三菱MR-J4-10A伺服器报AL32.4、AL32.1、AL24.2故障维修1例

分享到
10092
yuanyuesheng
文章数:1939
年度积分:623
历史总积分:10092
注册时间:2005/4/12
发站内信
发表于:2020/5/21 10:28:29
#0楼
一、用户主诉:
岛精123SP电脑横机,运行中控制触摸屏报摇床伺服器故障。
二、现场检查:
1、运行中控制触摸屏报摇床伺服器故障停车;
2、带电,查摇床伺服器历史故障报警记录,为AL32.4、AL32.1、AL24,2;
确认为伺服器故障。
三、维修室维修:
1、L11-L21接入200VAC,上电,4位LED数码报AL16.3,查历史记录,依次为:AL32.4、AL32.1、AL24.2;
2、查J4手册,AL16.3为编码器初始化故障;AL32.4为软件检测过电流;AL32.1为硬件检测过电流;AL24.2为接地故障;
3、因维修过程中未接入编码器,且装机运行编码器接入时未报AL16.3(编码器通讯故障),故此报警可以忽略;
4、记录故障报警代码;然后清除报警历史记录(P C018设置为1,断电,上电);
5、重新上电,出现AL16.3报警;查报警历史记录,只有AL16.3;
6、AL32.4、AL32.1、AL24.2故障报警均与输出电流检测有关,可以重点集中检查伺服器的输出电流检测电路;
1)观察检视,伺服器输出电流检测处理电路在电源驱动板,检测电阻为2个40m欧姆的电阻,脱焊母线滤波电容2后,可以看到其附近有2个丝印为C797的8脚芯片(比较厚实)。
2)通过测量证实,电流检测40m欧姆电阻是接入C797的2-3脚2端的,确认C797为电流检测芯片无疑;静态查其周边阻容元件,未见明显有误;
3)查C797芯片手册,型号为ACPL-C797,是一个“光耦线性放大西格玛编码输出”芯片。其1-4脚为输入侧直流+5V供电电源,5-8脚为输出侧直流+5V供电电源,7脚为时钟输入,6脚为编码输出。
4)因CPU电路板和电源驱动板是插座叠加连接,连接后不方便上电测量芯片供电电源,且C797输出端是编码,也不太方便用万用表测量判断好坏,故直接更换C797;上电试机,除仍报警AL16.3编码器未接入外,无新报警;
5)因除AL16.3编码器报警外,其它报警都是在运行中出现,故只能返厂现场装机试机。现场试机,控制触摸屏还报摇床伺服器故障。查报警历史记录,发现又出现AL32.4,其它报警AL32.1、AL24.2已消失;
6)继续维修,通过以上维修过程可以认定,上面的检测、维修思路正确,C797电路之前已经没有问题,应该继续查C797后面的信号处理。经测量发现,C797的6脚输出是送给了26LV31的芯片;查此芯片,为“低电压高速4差分线路驱动”芯片;直接更换;返厂装机试车,OK。

MR-J4-10A铭牌
附件 MR-J4-10A铭牌.jpg

电源驱动板1
附件 MR-J4-10A电源驱动板1.jpg

电源驱动板2(ACPL-C797电流检测芯片)
附件 MR-J4-10A电源驱动板2(ACPL-C797电流检测芯片).jpg

试机一
附件 修复J4试机一.jpg

试机二
附件 试机二.jpg
[此贴子已经被作者于2020/5/25 14:30:34编辑过]
556
xiaowuyong3534
文章数:20
年度积分:101
历史总积分:556
注册时间:2010/12/26
发站内信
发表于:2020/5/21 11:53:51
#1楼
留个爪,这个好详细,表情
10092
yuanyuesheng
文章数:1939
年度积分:623
历史总积分:10092
注册时间:2005/4/12
发站内信
发表于:2020/5/21 21:02:16
#2楼
现场试车时有个小插曲:
1、装机,上电,开车,初始化后,主控触摸屏报摇床位置不对。保全工说,伺服器有问题,摇床和前固定针板有错位。断电,经过手动转动摇床伺服器电机,对齐摇床位置后,上电,又出现同样情况。
2、查伺服器4位数码显示,无故障报警,编码器位置数码能够正常显示和随动。伺服器硬件应该正常啊!
3、难道是参数的问题?慢慢回想了一下,当初维修时,为了清除报警历史纪录,按照手册,需将伺服器P C018单元的参数值设置为1,然后断电,再上电,这一点没问题。可是当时调整P C018单元数时,似乎曾经有过误将P C019的值设置为1的过程,当时发现单元选择错误后,马上又把P C019的值特意纠正设为0。难道P C019的值本为1,“纠正”为0有误?
4、好在现场还有原装机运行正常的J4,立即查看其P C019单元数值,果然为1!
5、立即将修复的伺服器P C019设置为1,重新调整摇床初始位置。上电,运行,OK!

参数一时失误,几乎不明不白将吾前功尽弃!
[此贴子已经被作者于2020/5/21 21:23:18编辑过]
2970
Tivian
文章数:130
年度积分:353
历史总积分:2970
注册时间:2006/5/21
发站内信
发表于:2020/5/22 9:48:16
#3楼
经常修的J3报AL32.4,换过流检测光耦7860就可以了,26LV31还没换过
10092
yuanyuesheng
文章数:1939
年度积分:623
历史总积分:10092
注册时间:2005/4/12
发站内信
发表于:2020/5/22 11:25:00
#4楼
以下是引用Tivian2020/5/22 9:48:16的发言:
经常修的J3报AL32.4,换过流检测光耦7860就可以了,26LV31还没换过
J4没有A7860。
工控学堂推荐视频:

关于我们 | 联系我们 | 广告服务 | 本站动态 | 友情链接 | 法律声明 | 非法和不良信息举报

工控网客服热线:0755-86369299
版权所有 中华工控网 Copyright©2020 Gkong.com, All Rights Reserved

93.6