中国自动化学会专家咨询工作委员会指定宣传媒体
免费注册 登录 广告服务 | 客服中心
您现在所在的是:

人机界面

抖音 西门子减速电机 德嘉 台达 英威腾 泓格论坛 西门子 我和LOGO!有个约会 FLIR红外热像论坛 【有奖活动】英威腾 “Ni美国国家仪器 “PLC发展趋势大讨论”活动圆满结束 cc-link图文征集活动 西门子SMART LINE V3
工控论坛首页 人机界面 → 浏览主题: S7-200smart固件的一个小实验
发表新帖 回复该主题
回帖:7个,阅读:334 [上一页] [1] [下一页]
* 帖子主题:

S7-200smart固件的一个小实验

分享到
30721
tigermu 版主
文章数:13197
年度积分:1378
历史总积分:30721
注册时间:2004/8/12
发站内信
2018论坛优秀版主
2018春节活动(二)
2017论坛优秀版主
2017国庆活动(一)
2016论坛优秀版主
2016国庆活动(一)
2015论坛优秀版主
西门子logo体验(三)
英威腾PLC体验(三)
2015春节活动
2014论坛优秀版主
2013论坛优秀版主
2012论坛优秀版主
2010年度论坛贡献奖
发表于:2019/4/25 9:55:21
#0楼
看到论坛有人更新到2.4版本,新版本增加了modbus库和profibus net的支持,虽然我一时也用不到这样的功能,但恰好手头有ST20,而且购买时间也不是很长,可以尝试一下从软件更新固件的方法,遂做此实验。
从西门子官网下载了最新的smart编程软件V2.4以及需要的固件升级包V2.4。安装V2.4版本时还有小插曲,一直也没有解决。本身安装的是V2.2,想着覆盖安装也能行,结果运行安装程序称有以前的版本,需要卸载后才能安装。但奇怪的是,到控制面板里去卸载2.2时,提示程序丢失。无奈之下到目录里删除了程序,注册表也相应删了一些。然后按照2.4的时候能安装,启动之后提示MWSmart Executable已停止工作。按照网上提供一些方法,如“点击“用户配置”-管理模板-开始菜单和任务栏-不保留最近打开文档的历史,选中“禁用”确定即可”这种方法依然没有效果。也许还是旧版本有遗留的地方导致了无法再用(旧版本好使),因为没找到解决的方法,所以都是个人猜测。幸好手头还有一台计算机,免了做系统的尴尬,这台没装过西门子的软件,安装很顺利。
为了避免其他的干扰,硬件连接采取了计算机和plc直连的方式。连接后直接查找plc,发现固件版本为2.3,也就是说可以从软件本身升级。
附件 01进入更新.jpg
上图是进入到读取固件版本和更新固件的途径。菜单栏上“plc”,信息中的plc,即可进入到下图的“PLC信息”窗口。此窗口中可以读取连接的PLC信息,比如固件版本号。更新固件是在窗口底部的“固件更新”按钮进入。
附件 02v2.3版本.jpg
点击“固件更新”,进入到下图中,在更新文件,“浏览”中单击,把下载解压并和PLC型号对应的upd文件载入,点击“开始”,从进度条即可观察进度,这里是网络连接,速度较快,当然更新文件也小,时间估计在一分多钟那样。完成后有下图样的提示。需要重新对PLC上电。
附件 03更新完成.jpg
更新完的固件版本可以在plc信息里查到,确实是2.4了。
附件 04V2.4版本.jpg
更新完有了个想法,就是plc内部的程序受不受影响呢?当然增加的功能除外。因此随便写了两条梯形图,就是有输入有输出的。然后到官网下了V2.3的固件。更新回2.3后,发现程序依然好使,也就是说一定程度上能够保证程序不丢失和执行,这个没有去看西门子的文档,而且程序也过于简单,有些可能没去验证,大家当个参考吧。


清泉石上,明月松间。
22266
wenquan753
文章数:14144
年度积分:1536
历史总积分:22266
注册时间:2006/10/18
发站内信
2018论坛解答高手
发表于:2019/4/25 14:17:12
#1楼
固件更新肯定不会影响现有程序的运行
这就好比系统升级一样,肯定会向下兼容的
这应该是基本条件吧!
4571
zq3076
文章数:1859
年度积分:1070
历史总积分:4571
注册时间:2015/12/26
发站内信
发表于:2019/4/25 20:44:27
#2楼
200  smart  很好用 程序不大,不像博图。太卡
大连自动化工程 成套设备批发 钣金配电箱 APF SVG 电压低。
www apf7 cn                     张工           1 8 9 0 6 4 6 0 4 7 0
22462
mjinbao
文章数:13685
年度积分:1609
历史总积分:22462
注册时间:2013/1/12
发站内信
2018春节活动(三)
2017春节活动(三)
2016国庆活动(三)
发表于:2019/4/25 21:53:51
#3楼
从2.4又能回到2.3,觉得这点不错。
此帖发自手机工控论坛
15658
guanyumou 版主
文章数:7492
年度积分:1831
历史总积分:15658
注册时间:2008/7/13
发站内信
2018论坛优秀版主
2018春节活动(三)
2017论坛优秀版主
2017国庆活动(二)
2017春节活动(三)
发表于:2019/4/25 22:04:05
#4楼
虎版,网上不是说安装2.4直接覆盖安装即可!不用卸载原有版本的!
基于各种组态软件\触摸屏\PLC\单片机\变频器Modbus TCP\RTU\ASCII通信编程服务,需要请直接
联系!腾讯扣扣149034219
30721
tigermu 版主
文章数:13197
年度积分:1378
历史总积分:30721
注册时间:2004/8/12
发站内信
2018论坛优秀版主
2018春节活动(二)
2017论坛优秀版主
2017国庆活动(一)
2016论坛优秀版主
2016国庆活动(一)
2015论坛优秀版主
西门子logo体验(三)
英威腾PLC体验(三)
2015春节活动
2014论坛优秀版主
2013论坛优秀版主
2012论坛优秀版主
2010年度论坛贡献奖
发表于:2019/4/26 8:13:37
#5楼
以下是引用guanyumou2019/4/25 22:04:05的发言:
虎版,网上不是说安装2.4直接覆盖安装即可!不用卸载原有版本的!
我记得谁发过这个帖子,但我这里没好使,不知道什么原因,可能我图省事装的是ghost系统?
清泉石上,明月松间。
15658
guanyumou 版主
文章数:7492
年度积分:1831
历史总积分:15658
注册时间:2008/7/13
发站内信
2018论坛优秀版主
2018春节活动(三)
2017论坛优秀版主
2017国庆活动(二)
2017春节活动(三)
发表于:2019/4/26 11:21:54
#6楼
以下是引用tigermu2019/4/26 8:13:37的发言:
以下是引用guanyumou2019/4/25 22:04:05的发言:
虎版,网上不是说安装2.4直接覆盖安装即可!不用卸载原有版本的!
我记得谁发过这个帖子,但我这里没好使,不知道什么原因,可能我图省事装的是ghost系统?
有可能!不过我这里2.3到2.4安装是直接覆盖安装!没问题的!
此帖发自论坛APP
基于各种组态软件\触摸屏\PLC\单片机\变频器Modbus TCP\RTU\ASCII通信编程服务,需要请直接
联系!腾讯扣扣149034219
30721
tigermu 版主
文章数:13197
年度积分:1378
历史总积分:30721
注册时间:2004/8/12
发站内信
2018论坛优秀版主
2018春节活动(二)
2017论坛优秀版主
2017国庆活动(一)
2016论坛优秀版主
2016国庆活动(一)
2015论坛优秀版主
西门子logo体验(三)
英威腾PLC体验(三)
2015春节活动
2014论坛优秀版主
2013论坛优秀版主
2012论坛优秀版主
2010年度论坛贡献奖
发表于:2019/4/26 15:58:15
#7楼
哦,我安装的时候提示有以前的版本,需要卸载。
清泉石上,明月松间。
工控学堂推荐视频:

关于我们 | 联系我们 | 广告服务 | 本站动态 | 友情链接 | 法律声明 | 非法和不良信息举报

工控网客服热线:0755-86369299
版权所有 中华工控网 Copyright©2019 Gkong.com, All Rights Reserved

93.6